Warcraftlogs.com isnt allowing me to update my characters


#1

Hello, I am trying to get a logs page going for my guild upon its launch, and I have transferred a character to a new server, however, my warcraftlogs profile page isn’t allowing me to update my characters, cant find the guild and when I took away WCL’s permissions from my Bnet page, and put them back, still no fix. I even created a brand new account to see if I can fix it, still nothing.


#2

Update: using the link on the main page “No characters or guilds have been imported yet from Battle.net. Click here to import your characters from Battle.net, so that Warcraft Logs can discover what characters you own and what guilds you should belong to.” puts me back to the main page with this URL " https://www.warcraftlogs.com/?access_failed=true "


#3

We’re you able to make any progress on getting this resolved? I’m having the same issue. I unlinked, revoked the permissions from Battle.net account page, and re-linked it but its still not syncing and I am also getting the access_failed=true. I opened a ticket with Bliz to see if there was something wrong on my account but they report all is well on their side.


#4

Make sure you’re giving WCL permission to import your character profile. That box has to be checked.


#5

I have done both, and made sure I did it.

here is my proof


#6

I have also enabled the permissions requested as well, and am still having the same error you are. it looks like we both are in the same stuck boat.


#7

Try it on https:/beta.warcraftlogs.com … it has better error reporting, so might give us more of a clue what is going wrong.


#8

same effect, when I get this page (picture below)

I get the URL " https://us.battle.net/oauth/authorize?response_type=code&client_id=kwuy8gbg5v9putyc49x888ws6fm6j283&redirect_uri=https%3A%2F%2Fbeta.warcraftlogs.com%2Fblizzard%2F&scope=wow.profile&state=US-characters "

and then I see this page

yes I filled out the form too.

and Warcraftlogs(Beta) is now allowed on my Bnet page too


#9

Hmm the authorization is failing, and Blizzard is refusing to issue an access token. I’m not sure why.


#10

is there anything I can do about it? im the future raid lead of my guild and I used to live log all the time, so if I cant update my toons…I truthfully am at a loss


#11

What is your user name on the site?


#12

Zeerek, same as here