Can't sync characters


#1

I am having an issue where I can not update my characters. I can log in, approve battle.bet (the option box is checked) without a problem. When I attempt to sync the characters however, I wind up back at the main screen with the URL of : https://www.warcraftlogs.com/?access_failed=true

I have already tried removing the battle.net authorization and deleting the association in the account settings and starting the linking process over but I still have the same results.


#2

I had posted in a similar thread a week or so ago that I was having the same problem as another user. I tried the suggestion in that thread to use beta.warcraftlogs.com to see if that worked. I dont get the access_failed=true there, but the sync does not complete there either. I’m at a loss of where to go from here


#3

I’ll try to research Blizzard’s stuff to see if there is an error field I could be checking. I’m just not receiving an access token back from them. It’s just not there, but maybe they’re sending me an error code in some other field.


#4

I found some docs that seem to indicate that an error_description field will be set, so I’m going to modify beta.warcraftlogs.com to check for this and spit it out if it’s there. Should hopefully clarify what is going wrong.


#5

I also did some testing on my side. Whatever the issue is, its not exclusive to your site. Other sites that use the oauth account information methods also seem to be having problems syncing the character list. I had a developer API key for a website application, so I tried using the Community oauth testing tool from the dev.battle.net site to see if it would return my character information directly from blizzard.

Everything seems to work fine up until I attempt to pull the warcraft account information. that call errors with:

{
“status”: “nok”,
“reason”: “Internal server error.”
}

It looks like there is something weird on the blizzard side that is causing the API to throw a 500 error. The call to the starcraft profile returns just fine, its specific to wow. Hopefully this helps!


#6

Over the course of this issue I have opened a few tickets with blizzard. They have now acknowledged it seems to be a “known issue they are looking into”. Interestingly enough, it seems to also be impacting the ability to post to the official forums as that is also not authenticating things correctly. Had it not been for the forum impact, I would likely have never gotten them to acknowledge the issue.

For anyone else that seems to be having this issue, see if you can create a new thread on the forums. If you can not, it may be on blizzard’s side. The GM response says they will need another week to troubleshoot. I’ll post here once I have an update as well.


#7

I have been trying the API every few days since my last post to see if there has been any change. I was happy to find today that it seems to be fixed. Whatever bliz did also fixed the character sync so this is now working!