Unknown error when trying to install Warcraft logs

I’ve been trying to contact warcraft logs authors directly, but it didn’t work out , since outlook was being a little sketchy. For some reason, my Warcraft logs weren’t working properly, so I tried to uninstall which wasn’t working, so I thought downloading the client would do the trick, but I kept getting this weird error. I hope there is a way to fix this, otherwise, I will never be able to use the uploader ever again.

Your registry has gotten corrupted somehow. YOu’ll need to run Microsoft’s Fix It utility.

And how exactly do I do that?


“We’re sorry, but your operating system is not supported by Microsoft Fix it at this time.” this is getting better and better…

Might see what this guy used:

The tool which worked for this girl in the end was “FixMyPC” from TweakBit, it isn’t free, sadly but the free ones I tried (“CCleaner” and some I don’t remember the names of) didn’t get me any noticeable results.

Not sure why Microsoft doesn’t just release Fix It for Windows 10, when the problems with the registry obviously persisted.

Just googled the “fix it” thing and I found a similar website that solved my problem (works for windows 10 too!) . Here you go if others will be needing it : https://support.microsoft.com/en-gb/help/17588/fix-problems-that-block-programs-from-being-installed-or-removed