Unable to install Warcraftlogs Uploader, Error #0


#1

Hi,
I tried to update from 3.71 to 3.73 with no success for a while, thinking maybe the problem will fix itself with the next version(I don’t remember getting a prompt to update to 3.72 though)
Since 3.74 came out now I tried again and got the same error. It persists after uninstalling the uploader (as in it won’t let me reinstall it) and un-/reinstalling Adobe Air. A screenshot of the error: http://puu.sh/p4wR8/3eea42e71d.png
I also tried deleting the ELS directory as per Warcraft log uploader stuck in log in

Any tips where I could look for other possible solutions?

Edit: forgot to mention: I’m running Windows 10 64-bit


Unknown error when trying to install Warcraft logs
WarcraftLogs Error#0
#2

You probably have some registry key corruption in your Windows Registry. Run this:

https://support.microsoft.com/en-us/mats/program_install_and_uninstall/en-us


#3

This tool isn’t available for Windows 10, sadly. I’m looking for other ways to clear out the registry now. I’ll report back when I find something.

Thanks :slight_smile:


#4

Cleaning out the registry with one of those generic “PC cleanup” tools fixed it, thanks a lot for the help <3


#5

Getting the exact same error on Win10. Tried cleaning the registery, still not working for me.


#6

Ok so here’s how to manually fix your registery key (works with other apps that have installation problems, like my Mumble that was trying to install an older version than the installer I opened):

  1. Access the RegEdit by openning the windows menu and typing “regedit.exe”.
  2. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products
  3. Go down the list of keys and delete any that has a subkey “Product name” about Warcraftlogs or Adobe Air.

Cannot install the uploader?
#7

tyvm <3 worked


#8

Hi. It’s a simple problem actually. The problem is the Browser is not redirecting the program to the adobie air installer. It’s simple to fix. You should have a file called “warcraftlogs.air” in your download folder. Simply Right Click on the “warcraftlogs.air” file, select “Open With”, and if you have installed Adobie Air correctly the firs option will be “Adobie Air Application Installer”. Click on that, and wala…it installs without having to mess around with the registry. Remember that when it comes to Microsoft, the engineers always provide at least 3 different ways to do the same thing. Sometime ya gotta hunt for it, but it’s always there.


#9

Still having the same Problem. Did all the solutions mentioned before but still can´t install it… what should I do?
I´m running a windows 10 64bit , cleaned with Ccleaner, and manually like it was written above. Both didn´t work


#10

Yeah, I’ve been getting this issue and been unable to log in since 5.02 due to not being able to update.

I’ve done the same as Zaisaron and other suggestions in the thread - cleaned with CCleaner, manual registry key stuff, deleted ELS, opened with Adobe Air, made sure my system clock is set to current time, various un and reinstalls. Nothing’s worked.

Is there anything else?


#11

Did u ever get this fixed… I am having the same issue and have tried all of the above…?