Unable to Import Character/Guilds

I recently changed my battletag so I unlinked my bnet from warcraftlogs and relinked it. When I go to “Characters” there is nothing there, so I click “Update Characters”. After a few seconds of loading, it just goes to the front page and still no characters.

On the front page is says “No characters or guilds have been imported yet from Battle.net. Click here to import your characters from Battle.net, so that Warcraft Logs can discover what characters you own and what guilds you should belong to.”

I click that and it does the same thing. (Back to front page after a few seconds of loading).

I have tried this method below and it is still not working:
"First, unlink from Battle.net in Warcraft Logs. Then go to your us.battle.net page and make sure your Battle.net account is verified. If it is not you’ll see an exclamation point with a padlock.

If the account is verified, select Manage Authorized Applications and revoke Warcraft Logs’ permissions. Then go through the linking process on WCL again and this time make sure you give WCL access to character profile information. All boxes need to be checked."

Any help would be appreciated.

1 Like

I have no other suggestions sadly.

1 Like