Sorting Issue within the Logs


#1

Hi guys,

The logs seem to be showing in a haphazard form, not sorted and not in any order. I can’t seem to be able to click on a heading in order to sort from highest to lowest or vice-versa like previously before this WoW expansion. Am I doing something wrong, or is there a glitch on the site?

Thanks a bunch!

Carl


#2

Bosses are shown in the order you killed them (although if you have multiple weeks worth of kills, then bosses will get grouped together).


#3

I was thinking more like the healing and damage numbers, which are not in any sort of order.


#4

They absolutely are. What browser are you using? What page isn’t sorted? Sounds like you’re running into a JavaScript error in the page that is preventing a table from initializing its sort stuff.


#5

I was thinking it might be a browser error from the Chrome I was using, but I tried Firefox and Microsoft Edge, and and they (Damage, Healing, Healing Taken, etc.) still wont sort from highest to lowest, or vice-versa. It used to just fine for years up until now. Mind you, i’ts been 2 months and a few updates since we’ve raided. Maybe an update pooched it in the meantime? It’s a head scratcher for sure.


#6

Came here for the same reason. On the Damage Dealt and Damage taken pages, if the chart shows up out of order I can reload the page and it fixes it. The Healing page is never fixed and is always out of order. When the chart is out of order, the column headers are not clickable.

I mostly use Firefox (with NoScript), but had the same behavior with Microsoft Edge.

Was there a recent Javascript update I missed?


#7

I can’t reproduce this in any browser… tested with all of them.


#8

This is one of the pages I have trouble with:

https://www.warcraftlogs.com/reports/Z2YjTgm1VFGxJRaA/#fight=2&type=healing

If I then go to the “damage done” page for the same report, it’s out of order until I reload the page. I’ve tried it also on Safari on iOS.


#9

Thanks for the “reload” tip, Honesty, it seems to work for most categories except healing.


#10

Ah interesting; I can actually reproduce it on the link you provided. I’ll investigate. Thanks.


#11

Here is my link as well:
https://www.warcraftlogs.com/reports/HpJd6hYMDnm37q49#boss=-2&difficulty=0&type=healing

I just can’t get it to sort from high to low, or low to high.


#12

Seems to be working now for some reason. If you did anything, it worked!

Thanks for investigating!