Error "PrivateEncryptedDatak"


Hello all. Long time user of Warcraft Logs, and a Mac user. I have not had any problems until i recently updated the Adobe AIR application and the Warcraft Logs Uploader. The following message is given when i open the app or when I try to log in:

‘Warcraft Logs Uploader wants to use your confidential information stored in “Adobe.APS” in your keychain.’
‘The authenticity of “Warcraft Logs Uploader” cannot be verified. To allow this, enter the “PrivateEncryptedDatak” keychain password.’

I have tried ALL my passwords and none work, I have tried a complete reinstall and that does not work either.I have also tried deleting APS password in the keychain access and it still does not work. It doesn’t appear to be accepting any password at all? Whats up with this?


Fixing Mac EncryptedLocalStore database access error

This error is caused when the application is updated and the cached data stored in the /var/db/DeferredSignature file is out of date with the newly updated signature of the application. It seems that Adobe AIR actually iterates through this file looking for a matching signature. For some reason it stops (likely a bug) and no longer continues generating the appropriate Mac keychain to store the ELS key information.

To work around this problem you need to perform the following operations:

Cleanup the application data by deleting the data in
~/Library/Application SupportAdobe/AIR/ELS/XYZApplication

Delete the Adobe AIR keychain using the Keychain Access application on the Mac.
In the Keychains window you should see a Keychan called PrivateEncryptedDatak - right click on it and select Delete.
If the Keychain does not get removed from the list exit and restart Keychain Access.
If the PrivateEncryptedDatak keychain is still visible select the Keychain Access menu and the Keychain First Aid menu item. In the popup enter an administrator username/password, select Repair and hit start. The keychain should now be gone.

Okay, now the fun part. You need to start a terminal up - this will open up a shell window
If you are not logged in as an administrator you need to change the user this terminal is logged in as via the ‘su’ command by typing ‘su - username’ where username is the user you want to login as.
sudo rm /var/db/DetachedSignatures

Reboot the system. After rebooting, should be good and you can re-install the application.