4.3.5 WCL Uploader Crashing on start-up

Open WCL, crashes. New since 4.3.5 update.

same here. i just updated and go to sign in but get “error 3001”

Error 3001 indicates a permissions issue.

Do you have CS products installed? There may have been permissions issues with the shared Adobe folders.

Can you try renaming a couple of folders and testing the installation?

C:\Users\your_user_name\AppData/Roaming\Adobe (rename Adobe folder to oldAdobe)
C:\Program Files\Adobe (rename Adobe folder to oldAdobe)

note: AppData is a hidden folder, so you may have to change your view options to show hidden folders.

I’ve got the same. I used the old version both of the uploader and the Adobe AIR and I updated both at the same time. Crash. Tried to download again (both software), crash. Tried to rename the folders, crash.
Can you provide me a link with the former version? As I changed two things at once (ADOBE and the uploader), I want to isolate the problem by reverting to the previous version of the uploader first and will report the results.