Uploaded Parses no longer Ranking me + not going on my Public Profile

There are threads with the same problem, but none of them seem to have a solution given.
I’ve tried re-importing my character, toggling visibility, re-exporting + re-uploading the parse, etc, but nothing seems to work and it isn’t ranking me even though it’s working for other characters in the party and I have an orange parse.

It was happening earlier today in an A12S that 3 different people uploaded, and I thought it was just a one time bug.
But I went to A10S afterwards and the same issue: it’s not putting me in the rankings nor posting to my public profile.

Here is the first upload: https://www.fflogs.com/reports/TQpAbfYVkPrW74Mn
EDIT, reuploaded the run, still doesn’t rank me: https://www.fflogs.com/reports/bRYAN9BZcwkyPvpT

Hey, sadly I can’t help you with it. But I’m still insterested on your post because It happens exactly the same for me. Even that, I have had a12s down pre echo and last week it literally got DELETED from my logs (Tonitoni Chopper from Lich). Also right now it seems like i dont have any post-echo kills, even I have been parsed with my party/static. There is an example about today: https://www.fflogs.com/reports/9HBYLTNdKq7vFZb4/#fight=31. As you can see, I dont have any clue how good are my logs, and It pisses me off being kicked from PFs because people think I havent got it down. So i would appreciate a solution for me as well… Thanks for reading my message!