Rankings not exporting despite gold status

Hi, I’ve tried reuploading my logs multiple times now and it says that they’ve been successfully reuploaded, but my profile still only shows two Susano runs from the 26th - nearly 2 weeks of uploads haven’t been ranked. It shouldn’t be because of a queue because I’m gold on patreon. Any help?

Make sure you have claimed your character from Lodestone and see them in your imported characters list. Also double check that you’re uploading to the correct region if you’re putting your logs in your personal space (e.g., NA vs. JP vs. EU).

They’re not in my personal space (I don’t think I needed to choose a region in the first place), and reclaiming my character was one of the first things I tried despite already seeing it on the list.

I should add that the two parses from the 26th weren’t even uploaded by me - it was someone else in the pf group.

It just looks like this no matter how many times I try to export it. Also, you might need to fix the truncate timing lol