Problem getting characters from battle net

I can’t get my characters and guild from battle net. The battle tag is correct, and it tells me that the update is recent but no character appear. I have tried to update many times but it just reloads the page. I have also tried several times to remove the battlenet linking, remove Warcraft logs from battle et setting and linking again but with no success.
I would really appreciate any idea

I’m having the same issue

Are your characters high level? Low level characters are ignored. Also make sure you don’t have a million low level alts. There apparently is a cap on the # of characters returned by the API and they will omit your real characters if you have a super large # of low level alts on other servers that it finds first.

i have 7 110 characters and a few low levels. None of them appear, my character section is empty.
Hope this help finding the pb…

You probably didn’t give WCL authorization to view your characters. Unlink, go to, revoke WCL’s access completely, and go through the steps again. This time make sure you allow WCL to view characters.

Still not working… When i did the link again, i just have one box to tick. Can it be a pb of langage, as i’m in France? Should i choose a specifi langage (english or french) for it to work maybe?

when i try to log via battlenet with french chosen, i get a 400 error “autorisation ou URL non valide”

Try doing the linking with instead of and see if that works.

No success…
when i link to battle net, i have two lines:

  • battle net mail and battletag (no box to tick)
  • World of warcraft profile (one box to tick)

Am i missing something?

make sure to check everything you can.

There is just one box, so it’s ticked :slight_smile:

I’ve tried linking and delinking several times without success… It recognizes my battletag, say that the characters have been synchronized, but none of them appear… I have even deleted old level 1 alts just in case…

I’m out of ideas…

And your characters are level 100+?

On one server i have 7 110 and 4 90-100, and on another server 6 lvl 15-60 characters

If there is a fix for this I am having the same issue. Only one box to check for permissions. Everyone keeps saying check all the boxes. But I only see one. I checked the ONE box…