Missing guild after battle.net resync


We had an issue where the Discord webhook was not working and to try to fix this, I removed all my characters from WCL and relogged into BNET.

After doing so I can not post any logs on behalf of the guild and from looks of it the character on WCL seems to be guildless, despite being in guild in-game.

Before this, it was in guild and could post logs on behalf of guild just fine.

I’ve talked with the guilds GM and he does not see my character as “Member” in guild settings on WCL anymore (it was before), but does seem me in guilds character list on WCL.

Is there anything I can do here to fix this?

P.S. I’ve tried removing characters and done a resync…

Another super odd thing I just noticed is this

Character used to be on EU Sylvanas, then was transferred to Azjol-Nerub and back to Sylvanas, where it currently resides. From the above picture tells me the current character Failkin-Sylvanas is not on WCL. Perhaps I have misunderstood how “Character history” column is read?

Thank you in advance!

I can no longer pick up guilds from bnet syncing, since Blizzard removed guild info when they changed the API. You can go to the guild’s page on WCL and click Update upper right, and the roster should be updated to include you.

Thanks! We’ll try it and report back

It works now. Thank you, @Kihra