Issues with Warcraft logs Discord webhook

Hi, I would like to report an issue with the discord webhook. More so to do with the ‘Tools’ sections.

Currently it lists links to the Wipefest page with what looks like an attempt to put an emoji. So all the current members see is :wipefest: Click here to see wipefest, and the same for wowanalyzer it is just :wowanalyzer: with no actual icon.

I have tried adding these to my Discord manually, but the error is still the same. No icons, just a placeholder of text. It looks as if the icon is part of the hyperlink, that could be the root of the issue. I have also enabled the ‘Use external emojis’ permissions under the @everyone role.

See below for the example

Could this either be changed or removed?

These are the emojis added to my Guilds Discord.

Have you checked the specific channel permissions?

Hi all,

Apologies for the delay in a reply. I had managed to correct this issue. My Discord channel permissions were fine and all correct. It was however my Role permissions.

So for anyone else who could potentially be experiencing the same ‘issue’ as myself, there’s a couple things to check first;

Firstly, you want to check the Channel permissions of the channel that the web-hook is bound to (hover over the channel and click the cog icon), and navigate to the @everyone role - check that the permission ‘Use External Emojis’ is ticked.

If that doesn’t solve it, then you’ll need to look at the Role permissions it self under your Server settings. Again, find the @everyone role and ensure the permission ‘Use External Emojis’ is ticked.

After you know both are enabled, simply start a new log and the web-hook should know post correctly with emoji’s all working!

I hope that helps!

Hi @katskratches !

It wasn’t my channel permissions, however it was my Role permissions. I have posted a resolution above, so hopefully it helps anyone else!

Many thanks,