Webhooks do not appear to be working from WCL to Discord

Our last log was uploaded on 3/12 and the webhook was working properly. Our raid on 3/17 uploaded fine to warcraftlogs (live log) but the webhook did not show in our discord channel.

To test I have done the following:
recreated the webhook
added the new webhook to warcraftlogs (I am an officer in the guild and have this access)
created a live log (did not post to discord)
Added same webhook to github and pushed a code change from an unrelated project
The webhook from github worked as expected.

The only place I can not get this webhook to work (that I have tried) is warcraftlogs.

Anyone else experiencing this? I looked through the forums but didn’t see any other recent posts about it.

Webhooks are broken globally. I have no idea why. I didn’t change anything. I don’t know if Discord broke them or what.

Thanks for the confirmation. I feel better knowing it wasn’t just me.

Just to contribute some information:
When manually accessing a Discord-WebHook with curl or some other HTTP client it seems to work fine

curl -X POST -H “Content-Type: application/json” --data ‘{“content”:“Test”}’ “https://disco
rdapp.com/api/webhooks/123413355107975178/NotARealWebhookfLgba1qKD7s0GFjX0fwludhAqo-THvQmum_-Lm-3Eu0UaSeTMQmIeesLcz67

This has to do with the thumbnail format changing after migrating to new Blizzard APIs. Update your default profile character and then wait about 15 minutes for caches to clear. After that your webhook will work again.

That did it. Thanks for the suggestion.

I feel like a fool for typing this but: how do you change your default profile character?

I spent the last 15 minutes clicking around both worldofwarcraft.com and warcraftlogs.com…like a full on idiot.

The last of your characters that you viewed becomes your default.