Error that advanced combat log is not active, when it is. Cannot upload logs


I’ve been trying to upload logs after raid/m+ for the past few days, and I get the same error:

Error: Line 1 - This log was created without Advanced Combat Logging enabled, and is not supported on Warcraft Logs. You can enable Advanced Combat Logging from the Network pane of System preferences in-game. Delete your log file before enabling Advanced Logging, or this uploader will continue to refuse the file.-2/28 21:58:10.885 COMBAT_LOG_VERSION,14,ADVANCED_LOG_ENABLED,0,BUILD_VERSION,8.3.0,PROJECT_ID,1

I have tried:

  1. archiving the old combat log
  2. deleting and restarting a new combat log (ensuring advanced logging is enabled)
    • I have done this step multiple times
  3. uninstalling and reinstalling the uploader

If I remove the first line of the log, I can upload the log successfully, however it’s uploaded as a normal log w/o the ability to do any replay.

Is the first line of my log malformed? Or does anyone know if I can make manual edits to the line such that warcraft logs can read the log? The issue is that the line is generated by the game, so I’m not sure what is wrong.

thank you

If replay doesn’t work, then the log doesn’t have advanced combat logging on. :slight_smile:

Is there a process I can follow to fix this?

I have it selected in system > network
i’ve reset the interface option, and deleted/restarted the log many times.

My biggest confusion is that the log itself, has the ADVANCED_LOG_ENABLED tag on the very first line, and this is the line that the uploader is flagging as bad. If I removed this line and upload the log, things work. As for the actual logging, is there a state in which advanced_logging is enabled but the log itself is normal? I’m wondering if that might be the issue.

line in question:

thank you

That line says it’s off. You should see a 1 after ADVANCED_LOG_ENABLED.

1 Like