Can't Link to account

Hi all,

After i change server, i relink my account to my WCL account, it doesn’t show the correct guild (actually i have change my guild at the new server twice), and today i try to relink my account again, i got the following message when i use the link account URL at account setting page, it redirect me to and i sucessfully login and authorized, when it go back to, i got this:

Unhandled Exception

Undefined index: access_token


/var/app/current/application/controllers/accounts.php on line 377

Any help? Thank you~

Make sure you’re using to do this.

Thanks for the reply!!

I’m using to do this for sure, the URL redirect back to from is something like:

I don’t know what’s wrong, may be i should register a new account for a try?

I think i found the problem, when i click the link at WCL, it redirect me to, but automatically redirect me to for oauth access, therefore when it come back to WCL, it went wrong, if i change the URL to:

It will success but my account will said i have link to a KR region battlenet account, however my battle tag is correct but no charater will load correctly.

Is the oauth API changed or something? I think Korea region is represent Asia server and taking care of Taiwan account too?

same here.
connect another region will success but my account region is TW.

having sort of the same issue.did my registration and link my account.the battle tag is correct but when i try to link it to some character return me to same page and the URL change :

any action that might fix this problem?

So trying to understand this. Are you guys saying that is not being used by itself to authorize you? You are being redirected to

I think API of Blizzard has changed or something, because TW region is under ASIA district, and the API call will direct to I am a web developer, i can sure that something WCL has to been checked for TW region connect. Are you offical staff of WCL? Or can you transfer this case to WCL? Thank you.

Try it now and let me know if it works.

Oh great!!! It’s solved, thank you so much for your help!! Great work!

It works now. ty guys.