Unable to log into the Wow logs uploader


I’m unable to log into the warcraft logs uploader application. When trying to log in, It hangs and just spins forever.

I can log into the website fine.
Re downloaded the installer
re installed multiple times

re installed Adobe air as well
Deleted the Air/ELS folder multiple times.
Deleted the Air folder multiple times
Deleted these folders before loading WoW, during WoW, before Logging, and during logging.

Even if I type the wrong password it wont give me the error message.

My account isn’t linked to Bnet, But is my next step. Even though I didn’t really want to do it.

Checked all the other topics and deleting the ELS is the only fix that people have seemed to find success on. But there is a few instances where not!

Tried every combo I can think of with deleting the ELS folder?!

Ok Fixed it.

Deleted the Air/ELS folder whilst everything was closed down. Rebooted the PC straight after.

When PC was rebooted I loaded warcraft logs uploader and nothing else, and It logged me in straight away.