Guild Control Requests

  1. WoW
  2. Guild: Claws Not Paws Server: Dark Iron

I am an officer in our guild and for some reason one of our members is listing as an officer along with all of her alts. I have listed some of the folks in our top rankings below:

GM: Mclubss
Co-GM: Beanaround, Demonender, Enderlight, Healthydead, Navork
Officers: Enderstealth, Fangdingo, Izuldore, Kiler, Mclubs, Noravine, Runforit, Shazeem, Slaphappy, Slapnutz


Game: WoW
Guild: Chaosimpact - Blackrock EU

Current GM on the logs was an old officer (Sauerkirsche) who quit . Im the GM ingame on my character “Danteê”.

Thanks for the help.

still not fixed


GM: Subtly
Guild name: Dimensions
Server: Greymane

The officer who formerly uploaded logs has split from the guild and I need to be able to access them. Is there anyway you can fix this? Thank you!!


Still not fixed… Help would be great :l -bumb-


Game: World of Warcraft
GM: Domaee
Guild Name: Annihilation - Blackhand EU

I am the guildmaster and I created it.
But it’s a little strange situation because there is allready a guild registered called “Annîhîlation”(with those fancy roofs on the i) and for some reason I am in this guild with the rank -1 and my second officer also. But in WoW we are not!
And when we want to create our guild “Annihilation”, we get an error message, saying that there is allready a guild with this name.
When we created the guild ingame it was allready been taken, but it was inactive, so we wrote a gm ticket and the gamemaster set it free for us. Perhpas thats why there are some problems?

Best Regards


The problem isn’t resolved yet. Did you guys made any changes or something?



Game: World of Warcraft
Guild: Nerve - Blackhand EU

I’m the new GM. Aikanàro (Ingame) Atesch on Page.
The Old GM quiet and did not give me the GM on Page.


(1) The game (WoW, FF, WildStar or Rift).
World Of Warcraft
(2) Your guild’s name and the server the guild is on.
Server - Tarren Mill
Guildname - Vanguard Second Company.


Vanguard Second Company is managed, and I see you in the list already, so seems fine.


(1) WoW
(2) From the Ashes - Illidan- Horde

Guild has strange characters in the name, wont update with correct member list and wont give me guild control automatically. I also can not edit/delete logs and my profile wont update. I appreciate the help in advance!


You’re quick! Thanks so much!


HI Kihra

The Game : WoW
Guild: Amalon
Server Nethersturm EU

we have the Problem the old Guildmaster finish Wow,
now the guild going inactive and we want our name back :slight_smile:

before we use the name amalons … with the S on the end (But we cant use all features, Guild rouster etc)

now we need control over our Guildname: Amalon

I am not the guildmaster, but i was responsible for the logs.


WOW - EU-Malygos - Guild - Aêternitas / Aeternitas

Player Name “Shylynn”, Rank Officer but warcraftlogs does not let me take control over the guild.


You listed two guild names. Which is it?


Aêternitas with the fancy roof, but cant find it on warcraftlogs


update, can update logs but cant invite for upload


Game: WoW
Guild: Chaosimpact - Blackrock EU

Current GM on the logs was an old officer (Sauerkirsche) who quit . Im the GM ingame on my character “Danteê”.

Thanks for the help.

  1. WoW
  2. Exception - Ulduar
    Member made the guild some time ago without knowledge of officers. He has since left. Trying to rebuild now with Legion coming.
    I am rank 2,Cêrunnos which is officer.

Thanks for the Help

  1. WoW

  2. Frostmourne

D U R I A N ->
Esplanade ->

We recently did a guild name change (to Esplanade) and realized that the logs from the old guild name hasn’t been ported over. I tried porting them over but I don’t have the permission to do so as my character no longer has control over the logs under the old guild name (D U R I A N) after the system updated my character’s guild.

Thank you for your time.


Three weeks waiting. Could you resolve it guys? Thx