Companion App can't upload Logs anymore

My companion App stopped working yesterday.
Since then, I am not able to upload any logs to my account. I have already reinstalled the companion app, checked all necessary settings ingame and in the app itself.

For test I’ve got a log with 4 dungeons in it. When trying to select a specific dungeon to upload, the app gets stuck on “Reading Combat Log (100%)”. Even after minutes, nothing else happens.

When I try to upload the full log, it gets stuck on “Reading Combat Log (0%)” and just simply stops there. Nothing else happens.

In both cases, a log is created on the website, but with no fights in it.
Also, in both cases, canceling the upload doesn’t work. I have to manually shutdown the rpcoess via the taskmanager. It shows 10 different processes for Overwolf.

Does someone has the same issue OR has any idea on how to fix the problem? Would love to log again and analyse my playing to get better.

Edit: A mate which I ran most of the dungeons from the log I try to upload, could upload his own log by himself. So is it something with my log or something else? Live Logging doesn’t seem to work also…

Hey there! We’ve seen an increase in reports of this bug on the Overwolf companion. Would you be able to send us the error logs?

Go to System Tray → right-click Overwolf → Support → Create logs zip, and then can you mail this over to us on

Other troubleshooting ideas would be to fully log out of the app and then log back in. If that doesn’t work, you can also temporarily use the electron uploader - which you can find on the left here Warcraft Logs - Combat Analysis for Warcraft

1 Like

Hey Vel,

thanks for the information. I have already tryed to log out and in again on the app but it didn’t help.
I will send over the overwolf logs via mail as requested.
Further, I will try the uploader.

Thank you very much for your help as of now :slight_smile:

Best regards!

I have immediately tested with the uploader and it works just fine. Also I have send out the logfile for further inspection :slight_smile:

Thanks again for the help! As soon as I get information from the support and the issue is solved I will update the thread with the solution to help other people with the same problem!

Best regards,