Can't view complete logs : Error: Unable to fetch data

Having issues viewing logs on my Desktop Browser, tried Chrome, Edge etc all the same : They show like below :

If I view them on my mobile they load properly and I can see a breakdown of all characters etc.

I’ve cleared caches, deleted cookies, everything but still not working.

Anyone have any ideas?


Having this exact same issue. +1

Also tried clearing cache. Other troubleshooting steps:

  1. Rebooted computer
  2. Tried multiple different browsers
  3. Cleared pagefile

Just tried mobile after OP mention, on WiFi of same network as PC, works fine.

1 Like

Having the same issue.
Tried multiple web browsers (firefox, edge, chrome, brave, opera), all come back with the Unable to fetch data error.
Aside from the above mentioned steps, I’ve also reset my network adapter with no change in results.
Weirdly enough, in-game app does not have that issue.
Accessing the logs via my mobile from the same network works fine too.
Its just the web browser that has the issue.

Are you using NordVPN? If so, try turning off Threat Protection.

1 Like

MVP right here. THAT was the fix!

That worked, tho I just allowed warcraft logs through by clicking a small allow icon. The same happened also to Wowhead and just allowing it fixed my embedded problem there too.