HFC logs parsing but not uploading correctly

Our guild HFC runs are not uploading properly even though the loader appears to be parsing them correctly.

I’m running Warcraft Logs Uploader v4.07 on a Mac.

Last nights log was uploaded to https://www.warcraftlogs.com/reports/TXzZtW7KGh8gpw2r. But that is missing most of the fights.

It parsed correctly: this is what the fight list displays in the Uploader. All fights were selected and trash was off.
Uploader screen shot

The raw log is available for download at http://www.lightnings-hand.com/WoWCombatLog_20160815-235000.txt.zip

My guess is that Blizzard left out some ENCOUNTER_START or ENDs and it confused the parser on the server. Since the client figured it out correctly, I’ll see if I can figure out what is different there and migrate that handling from the client to the server. :slight_smile:

That seemed like a good guess, but I just checked the file, and there aren’t any missing ENCOUNTER messages. I also tried uploading again after the last update to the application, and the server is still missing fights.

These are the extracted ENCOUNTER messages and they match the pulls.

8/15 17:36:43.316 ENCOUNTER_START,1800,“Xhul’horac”,15,14
8/15 17:40:49.900 ENCOUNTER_END,1800,“Xhul’horac”,15,14,1
8/15 18:00:35.684 ENCOUNTER_START,1794,“Socrethar the Eternal”,15,14
8/15 18:04:46.886 ENCOUNTER_END,1794,“Socrethar the Eternal”,15,14,1
8/15 18:23:43.355 ENCOUNTER_START,1784,“Tyrant Velhari”,15,14
8/15 18:28:54.815 ENCOUNTER_END,1784,“Tyrant Velhari”,15,14,0
8/15 18:45:16.744 ENCOUNTER_START,1784,“Tyrant Velhari”,15,14
8/15 18:49:42.841 ENCOUNTER_END,1784,“Tyrant Velhari”,15,14,1
8/15 18:56:28.712 ENCOUNTER_START,1795,“Mannoroth”,15,14
8/15 19:02:49.321 ENCOUNTER_END,1795,“Mannoroth”,15,14,0
8/15 19:08:53.098 ENCOUNTER_START,1795,“Mannoroth”,15,13
8/15 19:16:04.616 ENCOUNTER_END,1795,“Mannoroth”,15,13,1
8/15 19:32:20.105 ENCOUNTER_START,1799,“Archimonde”,15,13
8/15 19:37:46.158 ENCOUNTER_END,1799,“Archimonde”,15,13,0
8/15 19:41:21.260 ENCOUNTER_START,1799,“Archimonde”,15,13
8/15 19:47:53.758 ENCOUNTER_END,1799,“Archimonde”,15,13,0
8/15 19:51:20.441 ENCOUNTER_START,1799,“Archimonde”,15,13
8/15 19:56:53.309 ENCOUNTER_END,1799,“Archimonde”,15,12,0
8/15 20:01:32.326 ENCOUNTER_START,1799,“Archimonde”,15,13
8/15 20:07:49.104 ENCOUNTER_END,1799,“Archimonde”,15,13,0
8/15 20:13:42.345 ENCOUNTER_START,1799,“Archimonde”,15,13
8/15 20:19:31.118 ENCOUNTER_END,1799,“Archimonde”,15,13,0
8/15 20:21:48.003 ENCOUNTER_START,1799,“Archimonde”,15,13
8/15 20:27:12.820 ENCOUNTER_END,1799,“Archimonde”,15,13,1

Just tried uploading your file from a Mac and it looks fine to me. What exactly was the error you were getting.

It isn’t throwing an error, but it isn’t showing all the fights at https://www.warcraftlogs.com/reports/DVNKJh1tCpWRGzFB

I just uploaded the whole file. Did you do Select Specific Raids and then select all of them by hand?

Just tried something different and the upload worked.

I disabled Select Specific Raids To Upload and the upload worked.

What I had been doing was enabling Select Specific Raids To Upload and selecting all of the fights. That option is not loading all of the fights even though they are selected.

Ah ok, will look into it.

1 Like

I just tried uploading an older file from six weeks ago with Select Specific Raids To Upload selected. It did not properly upload the file–but that log uploaded properly back in July and I would have used Select Specific Raids To Upload at that time.

Thanks! Let me know if I can provide any more info.