Warcraft Logs isn't working on Chrome for me

Last couple days I’ve been having an issue with WCL on Chrome. I get the new layout to select a fight, but when I select a fight I get a big black screen, other than the top left and top right being the same. I’ve tried updating chrome and restarting. If its not being whitelisted for adblock as the problem, I refuse to whitelist a site when their ads lag out Chrome.

I would suggest disabling all Chrome extensions just to see if that’s the cause. I would not expect this to have any connection to adblock, but maybe you have something else installed.

I turned off the only other extension I had, still the same issue. I however have tried in IE and Firefox and both work perfectly fine minus a little delay.

Did you turn off Adblock as well? Just trying to understand if it’s connected.

Turning off adblock just gave me 2 ads on top of each other. Still no actual logs.

Check your Javascript error console and see if report.js is throwing an error or something when you click a fight in the overview page.

I get 2 errors other than the adblock one

Uncaught TypeError: a.indexOf is not a function
at r.fn.init.r.fn.load (jquery.min.js:4)
at jquery.mCustomScrollbar.concat.min.js:5
at n (jquery.mCustomScrollbar.concat.min.js:4)
at jquery.mCustomScrollbar.concat.min.js:4
at jquery.mCustomScrollbar.concat.min.js:5

Uncaught TypeError: Cannot read property ‘msie’ of undefined
at jquery.ba-bbq.min.js:18
at jquery.ba-bbq.min.js:18

Those are expected. Hmmm, I am stumped. Everything works fine in Chrome for me, and I assume if it was a widespread Chrome bug, there would be a bigger outcry. Do you access the internet through a proxy server or anything weird like that? Wondering if you have some kind of stale files. Try emptying your cache in Chrome and see if that fixes it.

Emptying my cache seemed to fix the problem. Thanks for the help!